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 1 Introduction
The aim of this chapter is to show a new user of DCU Control System Platform a in
simple step by step procedure:

– How to set-up computer for DCU control design.

– How to set and program a new DCU unit using control design tools.

– How to set-up computer for DCU visualization.

 2 Installing DCU Control System Platform software

 2.1 Installed software
Complete DCU Control System Platform includes multiple software packages with
its specific purposes. The packages include:

– Java Runtime Environment (JRE). JRE is often already installed in operating
systems. If you are sure that Java JRE or JDK (Java Development Kit) is
already installed in your computer you may skip installation of JRE. DCU
Control System Platform supports any version of Java starting from version 5
or even earlier (not tested).

– W/M/L AMP (Windows/Mac/Linux Apache – MySQL - PHP) Stack. This
open-source  software  package  contains  database  (MySQL)  for  data
recording,  http  server  and its  tools  (Apache,  PHP) for  visualization using
web-pages. If an AMP stack is already installed in your computer, you may
skip installation of this component.

– Scilab/Xcos  computational  platform.  This  scientific  software  is  used  for
control design, programming, validation and optimization. Alternatively, you
may  use  another  version  of  Scilab/Xcos  starting  from  version  5.4.1  or
Matlab/Simulink starting from release 2008 or even earlier (not tested). 

– User Command Center (UCC) service. This is a Java application interface
service transferring data between control units,  design tools,  database, and
visualization web-pages.

– DCU  Design  Tool,  design  examples,  and  documentation.  This  is  an
interactive  toolbox  running  inside  Scilab  or  Matlab  platform  providing
comfortable interface for control design and programming.

 2.2 Simple installation using installer
Windows OS installation procedure 

1) Download Windows installer or Linux Ubuntu installer. 

2) In case of Windows, double-click the installer.  For Linux Ubuntu, unpack
installer files, open terminal and go to installer folder (for example by: cd
dcu-linux-2020-64bit)  and  run  command  ./dcu-install.sh.  Then  follow
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instructions  for  installation.  You may select  components  to  be installed if
your are expert, otherwise keep all components selected for installation. 

 2.3 Step by step expert installation procedure
In case of other operating systems such as Mac OS, or other Linux distributions, the
DCU platform may be installed step by step using separate packages.

Step 1 - Install Java Runtime Environment

On many operating systems Java Runtime Environment is pre-installed. To check if
JRE installed:

Windows OS

Open Command Prompt and type: 

java -version

Linux OS

Open a terminal program (xterm, Terminal, …) and type 

java -version

Response to  this  command should be displaying of  actual  version of  JRE.  If  the
response is that such command does not exist, JRE is probably not installed or its
directory is not registered within system environment. Check installed programs and
if java is not installed, install actual version of JRE:

Windows OS

Search for any Java JRE download for Windows on Internet (typically Oracle Java
JRE), download installer file, and double click the file to start installation.

Linux OS

For example on Ubuntu go to Ubuntu Software Center → Java →  OpenJDK Java
Runtime → Install, or open Terminal and type 

sudo apt-get install openjdk-8-jre
Step 2 - Install middle-ware and visualization software

Download  and  install  any  (W/L/M)AMP  (Windows  /  Linux  /  MacOS  Apache-
MySQL-PHP) package. For example:

Bitnami free LAMP stack for Linux, or WAMP stack for Windows, or MAMP stack
for MAC OS (http: : bitnami.com/stacks/infrastructure).

AMPPS free stack for Linux, or WAMP stack for Windows, or MAMP stack for
MAC OS (http: : ampps.com)

XAMPP free stack for Linux, or WAMP stack for Windows, or MAMP stack for
MAC OS  (https: : www.apachefriends.org/index.html)

Windows OS

Download installer file, and double click the file to start installation.

Linux OS
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Install MySQL server, Apache server, Phpmyadmin tool. The most actual installation
configuration  settings  can  be  found  in  dcu_ubuntuXX.sh  file  of  the  Ubuntu
installation folder.

Note: In case of visualization process data server, the computer has to be set to start
automatically after power failure. Also operating system needs to start automatically
without waiting on user boot selection. Example of setting these parameters for NUC
mini PC with Linux Ubuntu 12.04 is shown below.

1) Press F2 during minPC startup to call Bios. In Bios go to Advanced Setup - Power
and for the parameter “After Power Failure” select the option “Power ON”.

2) open grub file as a root by typing in terminal : sudo gedit /etc/default/grub

3) set parameter GRUB_TIMEOUT=3 (wait only 3 seconds with boot menu)

4) Add parameter GRUB_RECORDFAIL_TIMEOUT=3 (wait  only 3 seconds with
boot menu after a failure)

Step 3 - Install and set scientific control design platform

Free open-source control design platform is Scilab/Xcos. Supported version is Scilab
5.5.2,  higher  versions  has  minor  problems  with  Xcos.  Commercial  scientific
computational platform Matlab can be used as well, tested was version Matlab 2014,
higher versions may need to adapt DCU design toolbox. 

Scilab/Matlab are high-level scientific programming platform for signal processing,
dynamic modelling, identification,  control design and optimization. Xcos/Simulink
are Scilab/Matlab tool for drawing and simulating dynamic models. Download and
install  Scilab/Xcos  (www.scilab.org)  or  Matlab/Simulink  (from  your  Mathworks
account).  Because  the  DCU  design  tool  inside  control  design  platform  loads  a
dynamic  library  of  MySQL  database  and  a  library  of  UCC  interface,  on  some
operating systems, the libraries must be placed into correct operating system directory
and/or a C compiler needs to be installed. See below.

Scilab for Windows OS 

Download installer file, and double click the file to start installation.

Scilab for Linux OS 

Open Terminal, and type:

sudo apt-get install scilab

Older version of Scilab will probably be installed, but its components are necessary to
run new version of Scilab. When installation complete, download the newest version
of Scilab from www. scilab.org as compressed .tar file. Decompress the downloaded
file. To run Scilab go to decompressed Scilab directory scilab directory/bin and run
executable file “scilab”. 

Sometimes displaying of graphs (command plot) is not working properly. In such
case install graphic package libgl1-mesa-swx11 using command:

sudo apt-get install libgl1-mesa-swx11
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Matlab for Mac OS X

Download and install Matlab from Mathworks site according to instructions. Next,
copy MySQL library  from dcudesigntool/ucccalls/macos/libmysqlclient.18.dylib  to
standard operating system library directory, typically:  usr/lib/.

Matlab for Windows

Download and install Matlab from Mathworks site according to instructions. In case
of Matlab platform under Windows 64-bit operating system, appropriate c compiler
(Microsoft Visual C++) and development kit (Microsoft Windows SDK) needs to be
installed and properly set before using DCU design tool inside Matlab platform. To
check required compiler for any version of Matlab and operating system, see 

http://www.mathworks.com/support/sysreq/previous_releases.html

For  example in  case  of  Matlab R2009b and Windows 7 64-bit  operating system,
install  Microsoft  Visual  Studio  2008  Express  Edition  with  all  components  and
Microsoft Windows SDK for Windows Server 2008 and .NET Framework 3.5., see
explanation at

http://www.mathworks.com/matlabcentral/answers/98351-how-can-i-set-up-microsoft-visual-
studio-2008-express-edition-for-use-with-matlab-7-7-r
Sometimes it is also needed to indicate to operating system path to compiler and to
the installed compiler path to header files and to libraries. To set path to compiler,
add to the environment variable “Path” path to the compiler, for example:

C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64

To define path to header files and to libraries,  two operating system environment
variables need to be created: INCLUDE and LIB.

INCLUDE containing path to installed compiler include files

C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\include

LIB containing paths to installed compiler and SDK libraries

C:\Program  Files  (x86)\Microsoft  Visual  Studio  9.0\VC\lib\amd64;  C:\Program
Files\Microsoft SDKs\Windows\v6.1\Lib\x64

In case of 64-bit  Windows indicated libraries must be 64-bit  libraries. To add the
environment variables into Windows 7 environment, go to 

Control Panel\System and Security\System and click 

“Change settings”->”Advanced”->”Environment Variables”

Matlab for Linux

In case of Matlab platform on Linux copy MySQL library into appropriate system
library directory (/lib) or install MySQL C connector. Also fonts may be needed to
display properly user interface. To install fonts type:

To install fonts open Terminal, and type:

sudo  apt-get  install  xfonts-base  xfonts-100dpi  xfonts-
75dpi gsfonts-X11 gsfonts-other

When installed, start Scilab and in Preferences rise maximum used memory limits at
least to 2048MB or more to accelerate Scilab processing. To rise the memory limits,
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go to menu Edit→Preferences, section Java Heap Memory, rise limits and click OK.
When done,  close Scilab and on next  Scilab start  the new memory limits will  be
applied.

Step 4 - Download DCU design tool and UCC

Download (www.prosystemy.sk) and place into your computer DCU design toolbox
either for Scilab or for Matlab.  The package includes:

– DCU  design  toolbox  -  graphical  interactive  tool  for  programming  and
monitoring DCU. The toolbox is  developed in Scilab/Matlab environment
(running in Scilab/Matlab).

– Library  of  Xcos/Simulink  control  functions  for  programming DCU.  DCU
control application is drawn in Xcos/Simulink where it can also be simulated.

– Examples of control design projects.

– User  command  center  (UCC)  -  middle-ware  service  performing  all
communications with DCUs.

Step  5  -  Start  control  design  platform (Matlab  or  Scilab)  and  DCU  control
design tool

In case of Scilab environment, change actual directory of Scilab to DCU design tool
and type “exec dcudesign.sci”.

In case of Matlab environment, change actual directory of Matlab to DCU design tool
and type “dcu”.

 3 Start DCU Design

 3.1.1 Start installed DCU Design Tool
During DCU Control  System Platform installation shortcut  for DCU Design Tool
start is created. Click the shortcut, and all software necessary for design is started
automatically. Namely User Command Center, Scilab or Matlab design platform, and
DCU Design Tool inside design platform are launched. When launched you have to
first enter MySQL database login and password to UCC and then to Scilab/Matlab
window, see Figure  1. When login and password entered, UCC starts serving and
DCU Design Tool  main Window is  opened and user  may start  to  design control
system, see Figure 2. In case of Scilab Xcos windows may open as well. Xcos can be
closed for the moment, it is opened only for initialization purposes.

 3.2 Start DCU Design Tool component by component
Step 1 - Start MySQL database service

For  some  (L/W/M)AMP  package  installations  MySQL  service  is  started
automatically after computer restart. If not, start MySQL service manually:

Windows OS

For  Bitnami  WAMP  Stack  go  to  All  Programs  →  Bitnami  WAMP  Stack  →
wampstack manager tool. When the manager tool is started, start MySQL service.

Linux OS 
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Go to lampstack directory and run the file manager-linux.run. When the manager tool
is started, start MySQL service.

Step 2 - Start UCC service and connect to database

Windows OS 

Run the file start_ucc.bat in DCU design tool directory.

Linux OS 

Run the file start_ucc.bat in DCU design tool directory.

Enter the database login and password and click Start button to connect to database
and start  service.  Alternatively,  edit  the  file  autostart_ucc.bat  by  entering  correct
database login and password. Running autostart_ucc.bat file will then automatically
start  the  service  and connect  to  database using the specified login and password.
When started,  UCC service checks configuration database “dcuUserCommConfig”
for  configuration  tables  of  visualization  and  creates  (if  not  created)  process  data
history recording databases.
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Step 3 - Start control design platform and DCU design tool

Start Scilab or Matlab. In Scilab/Matlab go to directory containing DCU design tool
files: File → Change current directory. In Scilab command line type:

exec dcudesign.sci

In Matlab command line type:

dcu

Design tool will start and will asks for MySQL database login and password. Then, it
opens the main window of DCU design tool and in case of Scilab Xcos opens as well.
Xcos can be closed for the moment, it is opened only for initialization purposes.

 4 Basics of programming DCU

 4.1 Step 1 - Open an example of control design project
In DCU design tool go to Project → Open and select one example project from DCU
design examples, i.e. in example's directory select project file .prj. Project data are
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loaded into the design tool and displayed in the main window, see Figure 3. User can
now edit the opened project and its control application diagram.

 4.2 Step 2 - Modify control application diagram and simulate
Behavior of DCU is defined by control application diagram. The diagram is drawn in
Xcos (Simulink) dynamic simulator.  To open project's actual diagram go to menu
Design diagram → Open actual. Xcos/Simulink is started and diagram is opened.

Control  application  for  one  DCU is  defined  inside super-block (group of  blocks)
which  has  at  the  beginning  of  its  name  “dcu::”  string,  see  Figure.  Main  control
application may contain multiple DCU controllers. To edit control application of a
DCU, double-click the DCU super-block. The actual diagram of the corresponding
super-block  opens  and  user  can  start  add,  remove,  edit  control  functions  and  its
connections. All control functions are in library diagram that is in DCU design tool
directory. Notice, that control function has always at the beginning of its name the
string  “cfn::”.  It  indicates  to  translator  that  it  is  control  function  and  not  some
simulation block.

To define general parameters of a DCU controller (sampling times, IP address, users,
Modbus settings,...),  click right  mouse button on opened super-block diagram and
select “Set Context” (in Simulink click right mouse button on DCU block and select
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Edit  MaskInitialization  tab).  All  general  parameters  are  defined in  the  diagram
context (mask initialization) of the DCU, see Figure 5. 

To simulate control application diagram, click Start simulation button (empty right
arrow) in the main diagram (containing DCU super-blocks). Dynamic simulation is
launched. To define simulation settings, go to menu Simulation → Setup. 

Simulation may be slow due to large number of control functions. Therefore, it is
more efficient to 

– Create a new empty diagram (in main diagram menu File →  New diagram).

– Copy DCU super-block context into the context of this new diagram.

– Copy a part of control application to be tested in simulation into this new
diagram.

– Define desired simulation settings in Simulation → Setup.

– Place source blocks (steps, constants, signal generators) into the new diagram
and connect them to tested piece of control application.

–  Start simulation in the new diagram.

When satisfactory copy the validated part of the diagram back to main DCU diagram.

Finally export image of the diagram (click File→Export) as capp_xx.png file into
“project/Visualization/process/image” folder, where xx is the ID number of the DCU
unit, typically 11 (see Figure 4). It will be used for on-line visualization.

Figure 4 : Export of control application diagram into image.
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Figure 5: Control application diagram of a DCU.
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 4.3 Step 3 - Translate control application diagram
When all modifications of control application diagram are done, save the diagram.
Next click the button “Translate Diagram” in the main window of DCU design tool.
Translation process reads  diagram and save its  structure into XML file  ready for
download (file with extension .capp). When translation done, it appears in the list of
translations (first list from the top of the main window). 

 4.4 Step 4 - Connect designer computer to DCU
There are two possibilities for connection of designer computer with DCU, see Figure
4. In case of connecting to one DCU, computer may be connected to DCU using
Ethernet  crossover  cable.  In  case  of  connecting  to  a  network  of  DCU  (standard
Ethernet local area network is used for networking DCUs), computer is connected to
the network using standard Ethernet cable.

 4.5 Step 5 - Check/Set communication settings
Actual translation is shown in the translation list, translated DCU is displayed in the
control unit application list (below) with its communication settings, i.e. settings for
communicating with each DCU.

Selecting DCU application will display actual communication settings of the selected
DCU.  These  settings  are  initially  (after  translate)  taken  from general  parameters
specified  for  each  DCU  in  context  of  the  diagram.  If  modified,  the  settings  are
applied by clicking on the button “Apply Settings”.

To check if the communication settings are correct use the buttons on the left side of
the communication settings:

– Button “Is  Unit  Responding? Get  actual  state”  asks  DCU for  actual  state
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information and displays answer if some.

For examples in DCU design tool, communication settings are set to default values
preset in any new DCU.

 4.6 Step 6 - Load control application into DCU
To load  translated  control  application  into  selected  DCU  (selected  in  the  list  of
translated  DCU)  click  on  the  button  “Load  Control  Application  Into  Units”.
Communication settings are used for loading. 

For the first load of control application into a new DCU, its communication settings
are set default. If your control application settings differ from default values, use the
button “Load Unit With Default Comm. Settings”. Control application will be loaded
into DCU using factory default communication settings.  Successfully loaded DCU
appears in the list of on-line units. 

Now you can start control application inside control units. DCU tool asks to start the
application  after  application  load  or  click  “Control  Mode”  button.  Actual  control
application state is read and displayed together with Start/Stop application buttons.

 4.7 Step 7 – Start on-line DCU control and monitoring 
To start history recording of process control variables into database click “Hist.Rec.
On/Off”.  Actual  state  of  history  recording  is  displayed  together  with  Start/Stop
buttons.  Similarly  monitoring  may  be  started/stopped  by  clicking  on  “Monitor
On/Off”  button.  Monitoring  and  history  recording  are  the  same  procedures  of
recording  process  data  into  database.  Difference  between  monitoring  and  history
recording is defined by user. For each process variable/input/output user may define
sampling  time  for  history  recording  and  sampling  time  for  monitoring.  History
recording is intended for long-term visualization and archiving purposes. Monitoring
is intended for short-term on-line application validation by designer. If you are not
sure  about  your  process control  variable settings,  start  both history recording and
monitoring for first tests.

Buttons on the side of on-line units list allow user to 

– Display  general  parameters  of  actual  control  application,  button  “General
Parameters”.

– Get/Set DCU actual time and date, button “Get/Set Time/Date”.

– Start/stop control application, button “Control App. Mode”.

– Start/stop  monitor  recording,  button  “Monitor”.  History  recording  service
must be running on designer computer.

– Start/stop history recording. Again history recording service must be running
on designer computer.

Buttons  on  the  side  of  on-line  unit  elements  list  allows  to  enlist  control
functions/variables of selected on-line DCU (upper part) and to do operations over
control functions/variables (lower part).
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 4.8 Step 8 – Display on-line control application in web 
interface
First set users using menu Visualization Setup → Visualization Structure (see Figure
6). If not set, default users root with password root and oper with password oper are
defined.

Next set visualization server by Visualization Setup → Set Visualization Server

Figure 6: Setting visualization.

Next, in case of Windows, restart apache web-server, i.e. start Wampstack and click
Restart., see Figure 7. 

Figure 7: Bitnami wamp stack interface.

Finally  open  local  web-page  of  DCU  web  interface.  In  windows  the  link  is
127.0.0.1/dcu (web files are located in dcuproject/Visualization) in Linux the link is
127.0.0.1 (web files are located in var/www/html), see Figure 8.
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Figure 8: Default web interface.

Now log-in and go to Control System → Control Application, see Figure 9.

Figure 9: Control application web interface.
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